Active/Standby Data Centre Network Design using GNS3/Virtualbox/JUNOS/Cisco – Part-1

In this tutorial, I am going to build a MPLS core network using GNS3/Virtualbox and JUNOS Olive. Once completed, we will look into adding different features to implement Active/Standby Data Center design.

First step is to have your IGP running. I am using OSPF in this design. I will use LDP for label distribution MBGP for VPNV4 routes exchange.

So let’s begin with following steps:

1. Create three virtual machines by importing Olive into Virtualbox. I am using Olive version Olive12.1R1.9 Virtualbox image. These three machines will serve as 2 x PE routers and one P router for simplicity. 

part-1-1

2. Now import there machines into GNS3. Setting under GNS3 is same for three machines. I am showing GNS3 settings of one machine below:

part-1-2

3. Place all three machines in GNS3 and connect them together as shown below. I have named PE routers as karair3 and lahorir3. While P router is names as pakcore.

part-1-3

pakcore router is acting as our P router along with Router Reflector. We have two PE routers karair3 and lahorir3. I will create MP-BGP session from karair3 and lahorir3 to route reflector pakcore router to exchange VPNV4 routes.

4. Power-on all three machines. Once machines are up, you will be prompted to login. Use username as root and press enter to get into the machine.

5. Configure PE (karair3 and lahorir3) and P (pakcore) routers as following:

PE router karair3:

set system host-name karair3
set system time-zone Asia/Karachi
set system root-authentication encrypted-password "$Q.sdT9$aXZnvHSVyTzUM5Wt/B85V."
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 40.50.60.1/30
set interfaces em0 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 1.1.1.1/32
set interfaces lo0 unit 0 family mpls
set routing-options router-id 1.1.1.1
set routing-options autonomous-system 65000
set routing-options resolution
set protocols mpls interface em0.0      
set protocols mpls interface lo0.0
set protocols mpls interface em1.0
set protocols mpls interface em2.0
set protocols mpls interface em3.0
set protocols bgp group mp-bgp-internal type internal
set protocols bgp group mp-bgp-internal local-address 1.1.1.1
set protocols bgp group mp-bgp-internal family inet-vpn unicast
set protocols bgp group mp-bgp-internal neighbor 2.2.2.2 description to_pakcore
set protocols ospf area 0.0.0.0 interface em0.0 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface em0.0
set protocols ldp interface lo0.0

PE router lahorir3:

set system host-name lahorir3
set system time-zone Asia/Karachi
set system root-authentication encrypted-password "$1$m5bIr1x7nN50Fitn/"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em1 unit 0 family inet address 10.20.30.1/30
set interfaces em1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 3.3.3.3/32
set interfaces lo0 unit 0 family mpls
set routing-options router-id 3.3.3.3
set routing-options autonomous-system 65000
set routing-options resolution
set protocols mpls interface em1.0      
set protocols mpls interface lo0.0
set protocols mpls interface em3.0
set protocols mpls interface em2.0
set protocols mpls interface em0.0
set protocols bgp group mp-bgp-internal type internal
set protocols bgp group mp-bgp-internal local-address 3.3.3.3
set protocols bgp group mp-bgp-internal family inet-vpn unicast
set protocols bgp group mp-bgp-internal neighbor 2.2.2.2 description to_pakcore
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface em1.0 interface-type p2p
set protocols ldp interface em1.0
set protocols ldp interface lo0.0
 root@lahorir3> 

P router pakcore:

set version 12.1R1.9
set system host-name pakcore
set system time-zone Asia/Karachi
set system root-authentication encrypted-password "$1$F.STYfO4GkMRpg9b1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 40.50.60.2/30
set interfaces em0 unit 0 family mpls
set interfaces em1 unit 0 family inet address 10.20.30.2/30
set interfaces em1 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 2.2.2.2/32
set interfaces lo0 unit 0 family mpls
set routing-options router-id 2.2.2.2
set routing-options autonomous-system 65000
set routing-options resolution
set protocols mpls interface em0.0
set protocols mpls interface em1.0
set protocols mpls interface lo0.0
set protocols bgp group mp-bgp-internal type internal
set protocols bgp group mp-bgp-internal local-address 2.2.2.2
set protocols bgp group mp-bgp-internal family inet-vpn unicast
set protocols bgp group mp-bgp-internal cluster 2.2.2.2
set protocols bgp group mp-bgp-internal neighbor 1.1.1.1 description to_karair3
set protocols bgp group mp-bgp-internal neighbor 3.3.3.3 description to_lahorir3
set protocols ospf area 0.0.0.0 interface em0.0 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface em1.0 interface-type p2p
set protocols ldp interface em0.0
set protocols ldp interface em1.0
set protocols ldp interface lo0.0

6. Verify basic functionality from the core P router:

root@pakcore> show ldp neighbor 
Address            Interface          Label space ID         Hold time
40.50.60.1         em0.0              1.1.1.1:0                11
10.20.30.1         em1.0              3.3.3.3:0                11

root@pakcore> show mpls interface 
Interface        State       Administrative groups (x: extended)
em0.0            Up         
em1.0            Up         
lo0.0            Up         

root@pakcore> show ospf neighbor 
Address          Interface              State     ID               Pri  Dead
40.50.60.1       em0.0                  Full      1.1.1.1          128    33
10.20.30.1       em1.0                  Full      3.3.3.3          128    35
root@pakcore>        

root@pakcore> show ldp interface 
Interface            Label space ID        Nbr count   Next hello
em0.0                2.2.2.2:0                1           1
em1.0                2.2.2.2:0                1           2
lo0.0                2.2.2.2:0                0           0
root@pakcore>

7. And finally ping the loopback interfaces of the PE routers from P core router and verify the reachability

root@pakcore> ping 1.1.1.1 
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=64 time=0.517 ms
64 bytes from 1.1.1.1: icmp_seq=1 ttl=64 time=0.730 ms
64 bytes from 1.1.1.1: icmp_seq=2 ttl=64 time=0.473 ms
^C
--- 1.1.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.473/0.573/0.730/0.112 ms

root@pakcore> ping 3.3.3.3 
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=64 time=0.421 ms
64 bytes from 3.3.3.3: icmp_seq=1 ttl=64 time=0.792 ms
64 bytes from 3.3.3.3: icmp_seq=2 ttl=64 time=0.773 ms
^C
--- 3.3.3.3 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.421/0.662/0.792/0.171 ms
root@pakcore>

You should have now simple MPLS core in place to mimic the Service Provider network. I shall build further on in upcoming tutorial when I will add VRF on PE routers.

Advertisements

One thought on “Active/Standby Data Centre Network Design using GNS3/Virtualbox/JUNOS/Cisco – Part-1

  1. Pingback: Active/Standby Data Centre Network Design using GNS3/Virtualbox/JUNOS and Cisco – Part-2 | Markhorr Networks

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s